Power Automate Flow Error: There is no active transaction

Recently, got the below error while Saving the Power Automate Flow in Dev Environment.

“Request to XRM API failed with server error: ‘Message: There is no active transaction. This error is usually caused by custom plug-ins that ignore errors from service calls and continue processing. Code:0X80040251 InnerError: ‘- The tracking Id is xxx”.

Checked all the connections, whether is there any disconnections are not. But that is not the problem.

And later found that, the owner of the flow is not having any security roles.

Assigned the System Administrator Security role and tried to Save the flow, it worked.

Hope this resolution will help you to resolve the problem.

One thought on “Power Automate Flow Error: There is no active transaction

  1. Hi Arun Sir,
    I also faced similar kind of issue for OOB Classic workflow in one of my project and when checked found that owner of the workflow was a disabled user and assigned the workflow to valid user resolved the issue.

    Thanks
    Sainath Pillanagrovi

    Like

Leave a Reply to pillanagrovisainath Cancel reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.