Dynamics CE Workflow not triggering on a field change

I have a faced a strange issue that in one of the Dev environments, where Dynamics CE Out of the Box background workflow is not getting triggered on a field change.

So, for testing purpose selected As-an On demand process to test the workflow and surprisingly the workflow is working and it is not working on the field change.

Followed the below steps to resolve this issue.

Step 1: Open the required workflow.

Step 2: Click on Deactivate button to Deactivate the workflow.

Step 3: Click on Convert to a real-time workflow button.

Step 4: Click on Records fields changeSelect and make sure that all fields that requires for your workflow to trigger are checked.

Step 5: Click on Save and Click on Convert to a background workflow.

Step 6: Click on Save and Click on Activate the flow.

Step 7: Click on Activate.

After doing this activity, Background Workflow got triggered on the field change.

Hope you have followed the steps and resolved this kind of issue.

Please like and share your valuable feedback on this article.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.