Plug-in assembly does not contain the required types or assembly content cannot be updated.

Got the below error, while updating the Merged plugin dll in SIT environment.

Error Message - Detail

Started comparing the differences between Dev and SIT environments by navigating to

Microsoft Dynamics CRM -> Settings -> Customization -> Customize the System -> Plug-in Assemblies.

Clicked on the required Plug-in Assembly and started comparing the number of plug-in class files in it.

Plugin Assemblies

Found that, in the SIT environment have extra plug-in class files, which were imported in the beginning of the project and which were not present now in the updated Merged Plug-in Assembly Dll (Removed as per client requirement from the Dev code).

Finally, deleted those files manually in the SIT environment by connecting to the Plugin Registration tool and unregistered them.

Updated the required plugin assembly in SIT. It worked and issue resolved :):):)

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.